User Tools

Site Tools


routegadget:event_managers_guide

Guide for Orienteering Event Organisers

http://rg.orienteering.org.nz provides an open Routegadget service for all NZ orienteering events.

This guide is intended for clubs and event organisers who would like to upload their event to Routegadget. If you are an orienteer or competitor who is looking for information on how to use the NZ Routegadget, please refer to http://rg.orienteering.org.nz/

There are several steps to publish your event in the NZ Routegadget application:

  1. Event Planner prepares required files for RouteGadget (Can be done before or after race)
  2. Controller prepares Results and the Splits file (After race)
  3. Log into RouteGadget Manager area and add your event

1. Event Planner prepares required files for RouteGadget (Before Event)

Introduction

Generally, the faster you can upload the event onto RouteGadget following an event, the greater the number of people who will use it.

Four pieces of information are required to setup an event in Route Gadget. Some of this (Background Map, Courses File, and All Controls Map) can be created before the event and kept confidential by the Planner/Controller until the event is completed. (For example, on a USB micro drive kept by Controller).

Once the event is over and the results finalized, the Splits data can be generated and combined with the previously prepared files (or saved onto the USB micro drive) to upload the event onto RouteGadget quickly.

These instructions assume the person uploading results onto the clubs website and adding the event onto RouteGadget will be different to the Planner/Controller of the event, however this may or may not be the case.

Suggestion: always have multiple backups of your OCAD/CONDES course setting files.

The four pieces of information required to upload an event onto RouteGadget are:

  1. All Controls Map. (optional) This is a pdf or jpeg image of the entire map area used by the event with all controls shown on it. (Optional – only used for reference during the setup process to ensure controls are overlaid onto the background map correctly. If the person uploading the event onto RouteGadget will have a printed copy of the all control map or can view it directly in OCAD then you can skip this step).
  2. Background Map. This file is generated by OCAD. It is a single jpeg image file of the entire map area used by the event without any controls shown. Ideally it will include copyright and map details.
  3. Courses file. This file is generated by OCAD, CONDES, or Purple Pen. It is created from the OCAD/CONDES/Purple Pen event setting file and is generally also used by OE2010 to create the courses. This file tells Routegadget where each control is located on the map, relative to each other, and the course details.
  4. Splits file. This file is generated by the event software OE2010 after the event has concluded, and similar to what is uploaded to the winsplits website. It contains all the competitors, split times, and results.

1.1. Creating All Controls Map (optional)

The All Control location map:

  • Is a single image of the entire map area used during the event, showing all control locations
  • Can be created before the event and kept confidential
  • Recommended format is PDF or JPG, but it can be in any format. e.g. Printed Copy, OCAD, etc.
  • (Optional – This is only used for reference during the setup process to ensure controls are overlaid onto the background map correctly. If the person uploading the event onto RouteGadget will have a printed copy of the all control map or can view it directly in OCAD then you can skip this step).

Steps to create the All Controls Map:

  1. Start OCAD and open the Event Course Setting file
  2. In the right hand side Courses panel, In the Course drop down box select All controls and click on the Preview
  3. Export the Map from OCAD by selecting File > Export. The Export Panel will appear on the right hand side.
  4. In the Export drop down box select JPEG…
  5. In the Resolution drop down box select a value between 100 – 200 dpi e.g. 100
  6. Tick the partial map box and use either of the three boxes beside it to specify the area being exported. E.g. click on the Entire map button and then drag the defining edges to limit the area to be included, making it as small as possible to include the area used.
  7. Click OK. The Select Courses/Classes window displays
  8. Select <All controls> and click OK. The Export Jpeg File file save window displays.
  9. Save the file to the desired location.

1.2. Creating the Background Map

The Background Map:

  • Is a single image of the entire map area used during the event, and has no controls shown
  • Ideally includes map frame copyright information
  • Is 100-200dpi
  • Is as small a file as possible to reduce download size, without loss of detail when magnified.
  • Can be created before the event and kept confidential

Steps to create the Background Map:

  1. Start OCAD and open background map file used (Not the Event Course Setting file)
  2. Export the Map area required from OCAD by selecting File > Export. The Export Panel will appear on the right hand side.
  3. In the Export drop down box select JPEG…
  4. In the Resolution drop down box select a value between 100 – 200 dpi e.g. 150 (might have to use 175-200dpi if detailed sanddune terrain)
  5. Tick the partial map box and use either of the three boxes beside it to specify the area being exported. E.g. click on the Entire map button and then drag the defining edges to limit the area to be included, making it as small as possible to include the entire area used.
  6. Click OK. The Export Jpeg File file save window displays.
  7. Save the file to the desired location.

1.3. Creating the Courses file

  • This file tells the software where each control is located on the map, relative to each other, and the course details.
  • Can be created before the event and kept confidential.
  • IOF XML file format 2.0.3 is supported by Rotegadget. IOF XML file version 3 is not supported.

Steps to create the Courses Data using Condes:

  1. Export courses as IOF XML (version 2) Note: The default IOF XML Version 3 is currently not supported by Routegadget.

Steps to create the Courses Data using Purple Pen:

  1. Export courses as IOF XML (version 2). Note: IOF XML version 2 is currently the export default.

Steps to create the Courses Data using OCAD 9:

  1. Start OCAD and open the Event Course Setting file
  2. In the right hand side Courses panel, In the Course drop down box select All controls and click on the Preview button.
  3. Reset the location of the control letters, as if they are not in their default location problems will occur later on when you try to align everything in routegadget. i.e. Courses panel > Course: <All Controls> > Preview > Reset (All control code text/numbers will move to default position)
  4. Select Menu Course > Export > Courses (XML)… The Export Courses (XML) file save window displays.
  5. Save the file to the desired location.

Steps to create the Courses Data using OCAD 8 Software:

  1. Start OCAD and open the Event Course Setting file
  2. In the right hand side Courses panel, In the Course drop down box select All controls and click on the Preview button.
  3. Reset the location of the control letters, as if they are not in their default location problems will occur later on when you try to align everything in routegadget. i.e. Courses panel > Preview > Settings > Default (All control code text/numbers will move to default position)
  4. Export all controls (including start and finish codes) by selecting File > Export > DXF…
  5. Export courses by selecting File > Export courses… Follow the dialog boxes and save the files. This results in two files being generated: “courses.txt” and “anyname.dxf” (Where anyname is the filename you choose)

2. Controller creates Results and the Splits file (After Event)

The Controller checks the results and finalises the results. Once the results have been finalised and approved, they can generate the results for publishing on the club website and the splits file for upload into winsplits and routegadget.

2.1. Creating the Split file

The Split file is created after the event has finished.

Using SportSoftware’s Sport Ident OE2003 software:

  1. Select Competition day > Results. The Results window displays.
  2. Select Split times. The Select Report window displays.
  3. In the “Report type:” section select Classes
  4. In the “Split time results:” section select Standard
  5. Select OK. The Split Time Results window displays.
  6. Select Interface.
  7. In the File format: section specify CSV
  8. Enter the filename
  9. Click OK

3. Log into RouteGadget Manager area and add your event

3.1 Log into Routegadget Manager on rg.orienteering.org.nz

  1. In your Internet web browser visit: http://rg.orienteering.org.nz/ to go to the NZ RouteGadget Homepage.
  2. Click on the “Admin” Button. The Manager login screen will display
  3. Enter the username and password and click “OK”. The username & password can be requested by emailing webmaster@orienteering.org.nz
  4. The RouteGadget Manager Menu will display.

3.2 Add Your Event

  1. Click the Link “Add new event”. The Adding new event page will display.
  2. Select the appropriate radio button for each section and click “OK”.

For example, generally for OCAD9 and OE2003:

  • Raster map: select “1. Load new map”
  • Results add split times: select “SportIdent CSV”
  • Course settings: select “IOF-XML version 2 (Condes, Ocad9), no forking (Individual race)”
  • Leave “Use pre-loaded split time file”

The Adding new event page will display based on the options selected.

  1. Fill in all the requested fields and select the files for upload by clicking on the “browse” buttons
  2. When completed Click “OK”. The results of the upload of the files are displayed.
  3. Click on link “Adjust controls on the map”. The RouteGadget application starts and displays the background map on the left and control panel on the right.
  4. The map will show all the controls in a bunch somewhere on the map. Zoom by clicking on the +/– zoom buttons so you can see all of the controls. There may be some outside the map area.
  5. Align the control circles into their correct position on the map. Identify two control points which will allow good horizontal and vertical difference. For example top left most and bottom right most controls. Any two controls can be used but be sure it provides good top:down/left:right difference between the two. Repeat the following steps until they are all positioned in the correct location. If you need to pan/zoom the map, you can do this as part of the process:
  • Click, hold, and drag the first of the two outer control points you identified. It will turn red and move to the new location on the map.
  • Release the click. All controls will move based on the new control location.
  • Click, hold, and drag the other identified control. It will turn red and move to the new location.
  • Release the click. All controls (except the other red marker) will move based on that location.
  • On completion, the control circles will reposition on the map.

Note:

  • You can zoom in and out during this process by clicking on +/-.
  • It may take multiple attempts to position them correctly
  • You can drag the map by clicking the mouse on a blank part of the map and dragging the map and then releasing the mouse.
  • If something goes wrong, you can start adjusting from the beginning by reloading the page in your browser. Do not use the browser back arrow.
  • If you accidentally close the browser window or need to redo it, go back to the Managers menu, delete the event, and add it again. Please Note the map is not deleted when you delete an event so please either use the option to slect an existing map you previously uploaded or delete it to save space.
  • If the controls do not align on the map correctly, go back and recreate the courses data file (XML/dxf/txt file). In some cases, with OCAD you may need to reset the location of the control letters/numbers, as with some versions/file formats if they are not in their default location problems can occur. i.e. Courses panel > Preview > Settings > Default (All control code text/numbers will move to default position).
  1. Check all controls are positioned correctly and click “Save”. The Select courses for classes page displays.
  2. For each course, make sure the correct class/course from the results file is selected.
  3. When all are correctly matched, Click “OK”. If all everything works correctly, the page will change to display “Ready – Valmis!!!!”
  4. Click on “Manager Logout”. Logout OK! will be displayed.
  5. Click on link “Back to RouteGadget”. The Routegadget Menu is shown.
  6. Click on your event.
  7. Test the event is working correctly.
  • Use your internet browser to visit http://rg.orienteering.org.nz
  • Click on the link to “NZ RouteGadget”. The list of Events in Routegadget appears.
  • Right click on the Event name you wish to use
  • Copy the Internet link.
    • Firefox users: Select “Copy Link Location…”
    • IE users: Select “Copy Shortcut”
    • Safari users: “Copy Link”
  • Paste the address as the address in the results of your website.
  • Test the link works as expected.

5. References/Resources:

Contact:

NZ Routegadget is maintained by the ONZ Online Coordinator webmaster@orienteering.org.nz

routegadget/event_managers_guide.txt · Last modified: 11:50am Tue 26 July 2016 by onzadmin